My localhost WAMP on my personal Windows 10 machine just crapped out on me. PHPmyAdmin wouldn’t run I get the following on my screen when I go to my localhost website running in WAMP.

Error displaying the error page: Application Instantiation Error: Could not connect to MySQL.

My WAMP install I did without using a password for the PHPmyAdmin. It ran fine for a year and suddenly not.  What to do? I had stuff not backed up that I really wanted.

  • What if adding a password to the PHPmyAdmin fixes it…it didn’t.
  • Could it be my WAMP install and should I re-install on top of my already installed WAMP?

I looked deeply into the config.in.php file and playing around with that something did work. I used the solution on this page.

https://stackoverflow.com/questions/28541325/1045-cannot-log-in-to-the-mysql-server-in-wamp

Next I was lead to OS Training and an article using MySQL Console in WAMP. I never even knew it was there. It asked from my password. I put in the password I had just created in the config.ini.php file, but that didn’t work. I went back to my original blank password and I was in. I typed in

UPDATE mysql.user SET Password=PASSWORD(“root”) WHERE User=”root”;

That gave me the error.

ERROR 1820 (HY000): You must reset your password using ALTER USER statement before executing this statement.

Which lead me to updating the password for root.

set PASSWORD = PASSWORD(“What ever password”);

That did the trick. I was back into my websites and PHP my admin.

I hope this helps someone else out there…